use strict;
my $str = 'https://regex101.com/
ftp://daqdsqdq
azd ade zef ezfhttps://toto.dsdaz?page=1#sldlsdlsd&sqdqsd#sqdqsdsdza"ad azd azd
azd ade zef ezfhttps://toto.dsdaz?page=1#sldlsdlsd&sqdq;sd#sqdqsdsdza"ad azd azd
# OpenWrt Build System (PGP key for unattended snapshot builds)
curl \'https://git.openwrt.org/?p=keyring.git;a=blob_plain;f=gpg/626471F1.asc\' | gpg --import \\
curl \'https://git.openwrt.org/?p=keyring.git;a=blob_plain;f=gpg/626471F1.asc\' | gpg --import \\
from https://raw.githubusercontent.com/openwrt/docker/6d75cb142cba919faa74743c27c97b64c679a56a/docker-common.sh
# OpenWrt Build System (PGP key for unattended snapshot builds)
curl \'https://git.openwrt.org/?p=keyring.git;a=blob_plain;f=gpg/626471F1.asc\' | gpg --import \\
&& gpg --fingerprint --with-colons \'<pgpsign-snapshots@openwrt.org>\' | grep \'^fpr:::::::::54CC74307A2C6DC9CE618269CD84BCED626471F1:$\' \\
&& echo \'54CC74307A2C6DC9CE618269CD84BCED626471F1:6:\' | gpg --import-ownertrust
https://www.asd.google.com/search?q=some+text¶m=3#dfsdf
https://www.google.com
http://google.com/?q=some+text¶m=3#dfsdf
https://www.google.com/api/?
https://www.google.com/api/login.php
';
my $regex = qr/https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?\;])*(?:[-a-zA-Z0-9@:%_\+.~#?&\/\/=\;]*)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}