#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?):\d*"
Local $sString = "10.0.1.101:80 open" & @CRLF & _
"10.0.1.52:22 open" & @CRLF & _
"10.0.1.190:80 open" & @CRLF & _
"10.0.1.241:80 open" & @CRLF & _
"10.0.1.103:22 open" & @CRLF & _
"10.0.1.242:135 open" & @CRLF & _
"10.0.1.241:135 open" & @CRLF & _
"10.0.1.110:22 open" & @CRLF & _
"10.0.1.1:22 open" & @CRLF & _
"10.0.1.218:80 open" & @CRLF & _
"10.0.1.221:135 open" & @CRLF & _
"10.0.1.197:22 open" & @CRLF & _
"10.0.1.212:80 open" & @CRLF & _
"10.0.1.214:22 open" & @CRLF & _
"10.0.1.211:80 open" & @CRLF & _
"10.0.1.101:445 open" & @CRLF & _
"10.0.1.52:80 open" & @CRLF & _
"10.0.1.241:445 open" & @CRLF & _
"10.0.1.86:80 open" & @CRLF & _
"10.0.1.241:1433 open" & @CRLF & _
"10.0.1.217:80 open" & @CRLF & _
"10.0.1.101:8000 open" & @CRLF & _
"10.0.1.86:1433 open" & @CRLF & _
"10.0.1.101:443 open" & @CRLF & _
"10.0.1.106:135 open" & @CRLF & _
"10.0.1.115:443 open" & @CRLF & _
"10.0.1.220:80 open" & @CRLF & _
"10.0.1.210:80 open" & @CRLF & _
"10.0.1.219:135 open" & @CRLF & _
"10.0.1.115:80 open" & @CRLF & _
"10.0.1.212:8000 open" & @CRLF & _
"10.0.1.191:21 open" & @CRLF & _
"10.0.1.115:445 open" & @CRLF & _
"10.0.1.102:22 open" & @CRLF & _
"10.0.1.52:3306 open" & @CRLF & _
"10.0.1.217:443 open" & @CRLF & _
"10.0.1.190:135 open" & @CRLF & _
"10.0.1.192:135 open" & @CRLF & _
"10.0.1.191:445 open" & @CRLF & _
"10.0.1.111:443 open" & @CRLF & _
"10.0.1.210:443 open" & @CRLF & _
"10.0.1.105:80 open" & @CRLF & _
"10.0.1.198:22 open" & @CRLF & _
"10.0.1.218:443 open" & @CRLF & _
"10.0.1.106:80 open" & @CRLF & _
"10.0.1.115:81 open" & @CRLF & _
"10.0.1.220:1433 open" & @CRLF & _
"10.0.1.190:445 open" & @CRLF & _
"10.0.1.105:22 open" & @CRLF & _
"10.0.1.216:443 open" & @CRLF & _
"10.0.1.106:445 open" & @CRLF & _
"10.0.1.191:135 open" & @CRLF & _
"10.0.1.197:80 open" & @CRLF & _
"10.0.1.197:443 open" & @CRLF & _
"10.0.1.241:8080 open" & @CRLF & _
"10.0.1.216:80 open" & @CRLF & _
"10.0.1.210:8000 open" & @CRLF & _
"10.0.1.215:80 open" & @CRLF & _
"10.0.1.212:443 open" & @CRLF & _
"10.0.1.219:443 open" & @CRLF & _
"10.0.1.242:80 open" & @CRLF & _
"10.0.1.111:80 open" & @CRLF & _
"10.0.1.197:82 open" & @CRLF & _
"10.0.1.115:8080 open" & @CRLF & _
"10.0.1.105:443 open" & @CRLF & _
"10.0.1.221:443 open" & @CRLF & _
"10.0.1.219:80 open" & @CRLF & _
"10.0.1.86:21 open" & @CRLF & _
"10.0.1.219:445 open" & @CRLF & _
"10.0.1.192:445 open" & @CRLF & _
"10.0.1.192:21 open" & @CRLF & _
"10.0.1.191:80 open" & @CRLF & _
"10.0.1.242:445 open" & @CRLF & _
"10.0.1.215:8000 open" & @CRLF & _
"10.0.1.215:443 open" & @CRLF & _
"10.0.1.101:135 open" & @CRLF & _
"10.0.1.115:135 open" & @CRLF & _
"10.0.1.198:443 open" & @CRLF & _
"10.0.1.86:135 open" & @CRLF & _
"10.0.1.115:82 open" & @CRLF & _
"10.0.1.115:8888 open" & @CRLF & _
"10.0.1.192:82 open" & @CRLF & _
"10.0.1.216:8000 open" & @CRLF & _
"10.0.1.211:443 open" & @CRLF & _
"10.0.1.115:8088 open" & @CRLF & _
"10.0.1.191:8090 open" & @CRLF & _
"10.0.1.115:10000 open" & @CRLF & _
"10.0.1.111:9000 open" & @CRLF & _
"10.0.1.219:8099 open" & @CRLF & _
"10.0.1.211:9087 open" & @CRLF & _
"10.0.1.217:9087 open" & @CRLF & _
"10.0.1.218:9087 open" & @CRLF & _
"10.0.1.211:2020 open" & @CRLF & _
"10.0.1.218:2020 open" & @CRLF & _
"10.0.1.217:2020 open" & @CRLF & _
"10.0.1.115:20000 open" & @CRLF & _
"10.0.1.241:8009 open" & @CRLF & _
"10.0.1.211:9084 open" & @CRLF & _
"10.0.1.217:9084 open" & @CRLF & _
"10.0.1.218:9084 open" & @CRLF & _
"10.0.1.101:3000 open" & @CRLF & _
"10.0.1.192:83 open" & @CRLF & _
"10.0.1.192:90 open" & @CRLF & _
"10.0.1.211:9443 open" & @CRLF & _
"10.0.1.217:9443 open" & @CRLF & _
"10.0.1.218:9443 open" & @CRLF & _
"10.0.1.115:7088 open" & @CRLF & _
"10.0.1.115:8082 open" & @CRLF & _
"10.0.1.115:8300 open" & @CRLF & _
"10.0.1.210:8300 open" & @CRLF & _
"10.0.1.212:8300 open" & @CRLF & _
"10.0.1.216:8300 open" & @CRLF & _
"10.0.1.215:8300 open" & @CRLF & _
"10.0.1.115:8081 open" & @CRLF & _
"10.0.1.192:84 open" & @CRLF & _
"10.0.1.211:88 open" & @CRLF & _
"10.0.1.217:88 open" & @CRLF & _
"10.0.1.218:88 open" & @CRLF & _
"10.0.1.211:8084 open" & @CRLF & _
"10.0.1.217:8084 open" & @CRLF & _
"10.0.1.218:8084 open" & @CRLF & _
"10.0.1.210:9080 open" & @CRLF & _
"10.0.1.212:9080 open" & @CRLF & _
"10.0.1.216:9080 open" & @CRLF & _
"10.0.1.215:9080 open" & @CRLF & _
"" & @CRLF & _
"[*] 10.0.1.115 (Windows Server 2008 R2 Standard 7601 Service Pack 1)" & @CRLF & _
"[*] WebTitle:http://10.0.1.218:9443 400 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.191:8090 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.192:83 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.217:9084 404 Error 404 Not Found" & @CRLF & _
"[*] WebTitle:http://10.0.1.219 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.115:7088 404 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.115:8082 404 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.218:9084 404 Error 404 Not Found" & @CRLF & _
"[*] 10.0.1.242 (Windows Server 2008 R2 Enterprise 7601 Service Pack 1)" & @CRLF & _
"[*] WebTitle:http://10.0.1.211:9443 400 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.220 404 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.211:9084 404 Error 404 Not Found" & @CRLF & _
"[*] WebTitle:http://10.0.1.115:8080 404 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.52 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.115:8088 400 None" & @CRLF & _
"[*] WebTitle:https://10.0.1.198 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.217:9443 400 None" & @CRLF & _
"[+] ftp://10.0.1.191:21:anonymous " & @CRLF & _
" [->]10594_20110501035吴玮_2003.DOC" & @CRLF & _
" [->]aspnet_client" & @CRLF & _
" [->]cnki" & @CRLF & _
" [->]FILES" & @CRLF & _
" [->]weipu" & @CRLF & _
" [->]超星" & @CRLF & _
"[*] WebTitle:http://10.0.1.115:8081 200 title" & @CRLF & _
"[*] WebTitle:http://10.0.1.115 200 title" & @CRLF & _
"[*] WebTitle:http://10.0.1.115:8888 405 None" & @CRLF & _
"[*] WebTitle:https://10.0.1.101 404 None" & @CRLF & _
"[*] WebTitle:https://10.0.1.115 403 None" & @CRLF & _
"[*] WebTitle:https://10.0.1.212 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.105 200 None" & @CRLF & _
"[*] WebTitle:https://10.0.1.211 200 " + ID_VC_Welcome + "" & @CRLF & _
"[*] WebTitle:https://10.0.1.215 200 None" & @CRLF & _
"[*] WebTitle:https://10.0.1.219 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.197 200 Drcomɏµǂ¼´° " & @CRLF & _
"[*] WebTitle:https://10.0.1.216 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.101:8000 200 用户主页 - 广西科技大学 - 全球最大的虚拟现实三维互动在线教育云平台" & @CRLF & _
"[*] WebTitle:http://10.0.1.190 200 广西科技大学学位论文管理系统" & @CRLF & _
"[*] WebTitle:https://10.0.1.217 200 " + ID_VC_Welcome + "" & @CRLF & _
"[*] WebTitle:http://10.0.1.212 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.210 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.211 200 " + ID_VC_Welcome + "" & @CRLF & _
"[*] WebTitle:https://10.0.1.210 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.217 200 " + ID_VC_Welcome + "" & @CRLF & _
"[*] WebTitle:http://10.0.1.192:84 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.218 200 " + ID_VC_Welcome + "" & @CRLF & _
"[*] WebTitle:https://10.0.1.218 200 " + ID_VC_Welcome + "" & @CRLF & _
"[*] WebTitle:http://10.0.1.215 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.216 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.191 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.111:9000 200 平台登录" & @CRLF & _
"[*] WebTitle:http://10.0.1.115:82 311 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.192:90 200 None" & @CRLF & _
"NetInfo:" & @CRLF & _
"[*]10.0.1.241" & @CRLF & _
" [->]GYZCGL-SERVER1" & @CRLF & _
" [->]10.0.1.241" & @CRLF & _
" [->]171.168.2.7" & @CRLF & _
" [->]172.168.1.5" & @CRLF & _
" [->]2002:aba8:207::aba8:207" & @CRLF & _
" [->]2002:aca8:105::aca8:105" & @CRLF & _
"[+] InfoScan:http://10.0.1.52 Shiro " & @CRLF & _
"[*] WebTitle:https://10.0.1.197 200 Drcomɏµǂ¼´° " & @CRLF & _
"[*] WebTitle:http://10.0.1.241:8080 404 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.242 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.241 403 403 - ½ûֹ·Îʺ ·Îʱ»¾ܾø¡£" & @CRLF & _
"[*] WebTitle:http://10.0.1.219:8099 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.101 200 Home" & @CRLF & _
"[*] WebTitle:https://10.0.1.218:9443 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.86 403 403 - ½ûֹ·Îʺ ·Îʱ»¾ܾø¡£" & @CRLF & _
"[*] WebTitle:https://10.0.1.217:9443 200 None" & @CRLF & _
"[*] WebTitle:https://10.0.1.105 200 None" & @CRLF & _
"[*] WebTitle:https://10.0.1.211:9443 200 None" & @CRLF & _
"[*] 10.0.1.241 (Windows Server 2008 R2 Enterprise 7601 Service Pack 1)" & @CRLF & _
"[*] WebTitle:http://10.0.1.192:82 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.106 200 柳州市节能科技产业孵化园" & @CRLF & _
"[*] WebTitle:https://10.0.1.221 200 None" & @CRLF & _
"[*] WebTitle:http://10.0.1.115:81 400 None" & @CRLF & _
"[+] https://10.0.1.211 poc-yaml-vmware-vcenter-unauthorized-rce-cve-2021-21972" & @CRLF & _
"[+] https://10.0.1.218 poc-yaml-vmware-vcenter-unauthorized-rce-cve-2021-21972" & @CRLF & _
"[+] https://10.0.1.217 poc-yaml-vmware-vcenter-unauthorized-rce-cve-2021-21972" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")