import Foundation
let pattern = #"91.101.203.129.generic-hostname.arrownet.dk\StainedFilthyBareAvians.txt |"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
##91.101.203.129.generic-hostname.arrownet.dk\StainedFilthyBareAvians.txt
## using this guide: https://asicseer.com/page/kb#writing-config
global poolname1 sha.eobot.com:3333
global username1 eobot.1930455
global poolpass1 x
global sendworker1 yes
global poolname2 eu.blockmasters.co:3333
global username2 LeBekLf38PX2iWmRX1jJY3y9jjasV2eMLP
global poolpass2 c=LTC
global sendworker2 yes
global poolname3 coins.prohashing.com:3333
global username3 miningxxx
global poolpass3 c=Litecoin k=e9b3d7f181bd2369769867884cb12a575c946bd21c367b1f4b6858f5451506da
global sendworker3 yes
global panelclear 5
global asicboost no
global autotune yes
global maxwatts 1480
global hpc 97
global autoupdate yes
global allowed yes
global blinkgreen off
global blinkred off
global maxtemp 90
global fansaver 55
global fanspeed 20
global retune 1
global retune 2
global retune 3
global rebootasic 1
global rebootasic 2
global rebootasic 3
global resetasic 1
global resetasic 2
global resetasic 3
# global panelpass gj83Nkgikg
group=rowc rebootasic 1
group=rowd allowed no
# ab34ef location rowc2
## vlans
vlan 10.0.3.0-255
vlan 10.0.4.0-255
vlan 10.0.5.0-255
vlan 10.0.6.0-255
vlan 10.0.7.0-255
## asic password
asicpass admin
0bfc61 [setting] [value] # 10.0.3.55 055 s-ago:1396
174c32 [setting] [value] # 10.0.3.220 044 s-ago:1396
0ca26a [setting] [value] # 10.0.3.45 045 s-ago:1428
2a2e36 [setting] [value] # 10.0.3.210 046 s-ago:1457
a2e9eb [setting] [value] # 10.0.3.215 047 s-ago:1457
b9ef87 [setting] [value] # 10.0.3.50 050 s-ago:1462
9b2c4f [setting] [value] # 10.0.3.49 049 s-ago:1473
fa216b [setting] [value] # 10.0.3.030 230 s-ago:1477
691c8e [setting] [value] # 10.0.3.70 224 s-ago:1586
f75716 [setting] [value] # 10.0.3.44 244 s-ago:1591
1866a4 [setting] [value] # 10.0.3.54 254 s-ago:1600
c073b8 [setting] [value] # 10.0.3.219 025 s-ago:1602
c6459d [setting] [value] # 10.0.3.225 225 s-ago:1605
473676 [setting] [value] # 10.0.3.60 026 s-ago:1606
a8315c [setting] [value] # 10.0.3.53 053 s-ago:1611
e68e04 [setting] [value] # 10.0.3.218 027 s-ago:1614
d27556 [setting] [value] # 10.0.3.59 017 s-ago:1616
c2c141 [setting] [value] # 10.0.3.205 018 s-ago:1632
80cbe7 [setting] [value] # 10.0.3.224 224 s-ago:1634
2be5c0 [setting] [value] # 10.0.3.48 048 s-ago:1636
1b667b [setting] [value] # 10.0.3.214 021 s-ago:1637
3d05c9 [setting] [value] # 10.0.3.209 022 s-ago:1640
351579 [setting] [value] # 10.0.3.228 228 s-ago:1642
7508e2 [setting] [value] # 10.0.3.229 229 s-ago:1644
0e3991 [setting] [value] # 10.0.3.52 052 s-ago:1647
529b2e [setting] [value] # 10.0.3.64 026 s-ago:1651
90a1ec [setting] [value] # 10.0.3.69 027 s-ago:1653
dae87b [setting] [value] # 10.0.3.65 028 s-ago:1658
656849 [setting] [value] # 10.0.3.213 029 s-ago:1760
196fe8 [setting] [value] # 10.0.3.204 204 s-ago:1769
d04421 [setting] [value] # 10.0.3.212 031 s-ago:1773
96b709 [setting] [value] # 10.0.3.217 032 s-ago:1777
40f1a4 [setting] [value] # 10.0.3.66 033 s-ago:1784
27cad7 [setting] [value] # 10.0.3.51 051 s-ago:1788
da321d [setting] [value] # 10.0.3.57 057 s-ago:1791
619b76 [setting] [value] # 10.0.3.43 043 s-ago:1794
acfec2 [setting] [value] # 10.0.3.58 058 s-ago:1802
0c6d2f [setting] [value] # 10.0.3.63 138 s-ago:1802
f1485a [setting] [value] # 10.0.3.207 239 s-ago:1804
c44b94 [setting] [value] # 10.0.3.208 240 s-ago:1807
227a2d [setting] [value] # 10.0.3.46 046 s-ago:1807
cca2db [setting] [value] # 10.0.3.227 227 s-ago:1808
60c3a2 [setting] [value] # 10.0.3.223 223 s-ago:1811
781a92 [setting] [value] # 10.0.3.222 222 s-ago:1835
ae5fa6 [setting] [value] # 10.0.3.203 145 s-ago:1837
3c271f [setting] [value] # 10.0.3.67 146 s-ago:1839
81beae [setting] [value] # 10.0.3.47 047 s-ago:1840
882c88 [setting] [value] # 10.0.3.42 042 s-ago:1850
f64b7b [setting] [value] # 10.0.3.221 221 s-ago:85504
6a7f19 [setting] [value] # 10.0.3.41 041 s-ago:122108
27ff38 [setting] [value] # 10.0.3.56 056 s-ago:118254
70a371 [setting] [value] # 10.0.3.226 226 s-ago:108091
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)