$re = '/(?<=[a-z]|)\s(bin|binti|a[\\\\\\\\\/][lp])\s.*/i';
$str = 'Muthu Kumar A\\L Ragusami';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);