$re = '/(?<=perro)/m';
$str = 'El perro de san roque no tiene rabo porqué Ramon Rodríguez se lo ha robado.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);