import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"(http.+appl(?:y|ica).*?)\"";
final String string = "<div>\n"
+ " <p>Erste Fragen beantwortet Ihnen gerne Elcin Rabatli-Klappenberger\n"
+ " unter <a href=\"tel:+49/839868144\"><span\n"
+ " class=\"brand-color text-bold\">0891/898568144</span></a>.</p>\n"
+ " <p>Bewerben können Sie sich einfach mit Ihrem Lebenslauf über unsere\n"
+ "<a href=\"https://www.pisegxel.de/java-spring-jee-softwareentwickler-architekt-muenchen\"\n"
+ " target=\"_blank\">\n\n"
+ "<p>Informationen über uns und zum Bewerbungsablauf\n"
+ "finden Sie unter <a href=\"https://www.isg.com/jobs/applications/applyForJobEntry.jsf?inseratnummer=83115&refererId=37\" target=\"_blank\"><span\n"
+ " class=\"brand-color text-bold\">www.pisegxel.de</span></a></p>\n"
+ " <span\n"
+ " class=\"brand-color text-bold\">>>> 1-Klick\n"
+ " Bewerbung</span></a> oder per Email über <a\n"
+ " href=\"mailto:jobs@pisdgexel.de\"><span\n"
+ " class=\"brand-color text-bold\">jobs@pissegxel.de</span></a></p>\n"
+ " \n"
+ " <p><span class=\"brand-color text-bold\">Informationen zum Ablauf in\n"
+ " Bezug auf COVID 19:\n"
+ " </span><br />\n"
+ "<a href=\"https://www.pisegxel.de/application/java-spring-jee-softwareentwickler-architekt-muenchen\"\n"
+ " target=\"_blank\"> \n"
+ " Vorstellungsgespräche können via Videokon­fe­renz\n"
+ " geführt werden. Alternativ\n"
+ " ist bei Präsenzterminen die Einhaltung der Hygienevorschriften gewährleistet.<br />\n"
+ "<a href=\"https://www.pisegxel.de/apply/form?job=333&test=2\"\n"
+ " target=\"_blank\">\n"
+ " <strong><em>Wir freuen uns auf Ihre Bewerbung!</em></strong>\n"
+ " </p>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}