$re = '/Birthday\s*(.*)\s*Age\s(.*)/';
$str = 'Sample 3
Birthday April 4, 1994
Age 27 years old
Gender Male
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);