# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([A-z]+)(?: *= *)(\d+|[A-z]+)$"
test_str = ("Expression validator\n"
"^((?:[A-z]+)|((-|\\+)?\\d+))( +(\\++|-+) +((?:-?\\d+)|(?:[A-z]+)))*$\n\n"
"Assignment validator\n"
"^([A-z]+)(?: *= *)(\\d+|[A-z]+)$\n\n"
"c= a\n"
"8\n"
"8 + 4\n"
"-2 + 4 - 5 + 6\n\n"
"9 +++ - 10 -- 8\n"
"9 --- + 10\n"
"9 --- -10\n"
"9 +++ -10 -- 8\n"
"3 --- 5\n"
"14 - 12\n"
"-3 2\n"
"name = 44\n"
"a = 5\n"
"capName = 6 + 4\n"
"capName = 6\n"
"n = 3\n"
"m=4\n"
"a = 5\n"
"b = a\n"
"v= 7\n"
"n =9\n"
"c= a\n"
"A variable can have a name consisting of more than one letter.\n\n"
"count = 10\n"
"To print the value of a variable you should just type its name.\n\n"
"N = 5\n"
"N\n"
"5\n"
"It should be possible to set a new value to an existing variable.\n\n"
"a = 1\n"
"a = 2\n"
"a = 3\n"
"a\n"
"3\n"
"If an identifier or value of a variable is invalid, the program must print a message like the one below.\n\n"
"a1 = 8\n"
"Invalid identifier\n"
"n = a2a\n"
"Invalid assignment\n"
"a = 7 = 8\n"
"Invalid assignment\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.