#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^La.+?no\s*(?'num_externe'.+?)\s.*\s(?:^.*\n)*.*installation\s*:\s*(?'ins_numins'.+?)\s+.*:\s*(?'apt_localisation'.+?)\s+.*:\s*(?'apt_nom'.+?)\s+.*:\s*(?'apt_email'.*?)\s+Typologie:.*\s*Motif.+?:\s*(?'qsy_lib'.+?)\s*Demande:\s*(?'commentaire_externe'.+)"
Local $sString = "Demandes - Date: 03/06/2019 à 09:58 " & @CRLF & _
"La demande no 117530 a été externalisée à NORD ENGIE-Cofély, " & @CRLF & _
"Site concerné: " & @CRLF & _
" - Numéro d'installation : 2870521005 " & @CRLF & _
" - Nom du Site : APE ST YRIEIX " & @CRLF & _
" Chargé d'affaire: Aurelie GUILLON " & @CRLF & _
" Email: " & @CRLF & _
" " & @CRLF & _
" Typologie: Forfait heures multiservices " & @CRLF & _
" Motif détaillé: Demande " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" Demande: Objet : fixer la boîte à pharmacie petit format au mur. Bonjour, Je sollicite une intervention pour fixer la boîte à pharmacie petit format au mur en zone d'accueil à côté de l'extincteur. Cordialement. Sylvain CLUZEAU." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")