import Foundation
let pattern = #"^\s*(.+?)\s*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" Хозблок 4х3 «Выгодный» - максимально выгодное предложение на рынке домостроения Настоящий проект хозблока 4х3 – это один из самых универсальных проектов садового домика в линейке хозблоков Топсхаус. И учитывая его очень доступную стоимость, то, несомненно, и самый выгодный. Независимо от того, что потребуется заказчику, начиная от жилого дома и заканчивая обустройством сарая для животных, размеры и планировка хозблока из бруса «Выгодный» продуманы и актуальны для применение в любом качестве. Для жилого использования в двух его комнатах (6,3 и 3,6 м²) можно оборудовать небольшую спальню и кухню/санузел, превратив хозблок, например, в строительную бытовку на время возведения основного дома. Можно оставить хозблок 4х3 в таком виде для дальнейшего размещения гостей, это отличный вариант. Но если гостевой домик не требуется – превращаем нашу бытовку в зону складирования необходимых дачных предметов или в мастерскую, функционирующую автономно и независимо от прочей инфраструктуры. И как летняя кухня хозблок будет весьма неплох. Даже как легкая и компактная баня. Внешне симпатичный и аккуратный, хозблок 4х3 идеально впишется в свободное пространство и станет буквально палочкой-выручалочкой при возникновении новых задач. А благодаря исключительной надежности и удобству монтажа, «Выгодный» избавит от проблем последующие поколения благодарных дачников, многократно подтверждая свое название. "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}