$re = '/([ابپتثجچحخدذرزژسشصضطظعغفقکگلمنوهی ]+)/i';
$str = 'تست متن فارسی';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);