#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<type>SLA)(?:::)(?P<sa>[0-9]{4,7}|(?:_))?(?:::)(?P<cid>[a-zA-Z-0-9-/._]{8,}|(?:_))?(?:::)(?P<ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}|(?:_))?(?:::)(?P<desc>[\w#()/-]*)"
Local $sString = "SLA::3223453::801-4259::10.224.0.88::PIONEERLAND_DASSEL" & @CRLF & _
"SLA::3223482::_::_::PIONEERLAND_RAYMOND" & @CRLF & _
"UNI::3238811::ROCHESTER_COMMUNITY_COLLEGE" & @CRLF & _
"SLA::_::_::10.224.0.88::PIONEERLAND_WILLMAR_DC" & @CRLF & _
"SLA::3211691::A1Q0041C::_::TMOBILE_511_PARK_AVE" & @CRLF & _
"SLA::3206176::EEVC/011439//2636/EPL::10.252.51.50::CHARTER_BANK" & @CRLF & _
"SLA::3206176::_::10.252.51.50::CHARTER_BANK" & @CRLF & _
"SLA::3223621::70.VLXP.024011..CBCL..::_::GOEBEL_FIXTURES_COMPANY" & @CRLF & _
"SLA::3178253::KRE1/50393/MPT/CTTNMNTMOB1::10.224.0.88::TMOBILE_COTTON" & @CRLF & _
"ACCESS::DSLAM_TEST" & @CRLF & _
"SLA::3265812::L2XN/77798/MPT/LRTOMNARPF::10.224.0.159::CCI_ARROWHEAD_PROMOTION" & @CRLF & _
"SLA::3152953::180-361-0266::10.252.51.101::HORMEL_BLOOMING_PRAIRIE" & @CRLF & _
"SLA::3137605::GEYX/065858::10.252.2.203::ZAYO_VZW_KIMBALL" & @CRLF & _
"SLA::3171637::88/INFR/102977//DCE/::10.252.2.25::BNC_BANK" & @CRLF & _
"SLA::3182788::150-368-0293::10.252.51.36::NORTHFIELD-HOSPITAL" & @CRLF & _
"SLA::3221907::EVENT_41767_PEARL_LAKE_LIT::10.224.0.166::VZW_PEARLLAKE" & @CRLF & _
"SLA::_::_::_::VZW_GP_RED_WING_WEST" & @CRLF & _
"SLA::3227386::16-KFLA-01156--NVP::_::ZAYO_DULUTH_GROUP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")