use strict;
my $str = '<tr>
<td class="no-min-width " style="" width="45" data-col="0">
<a href="/[ステージオブマジック]島村卯月">
<img src="https://cdn.img-conv.gamerch.com/img.gamerch.com/imascg-slstage-wiki/wikidb_thumbnail/338316/individual_200.jpg?d=20190419162924&q=20" class="lazy ui_thumbnail" data-original="https://cdn.img-conv.gamerch.com/img.gamerch.com/imascg-slstage-wiki/wikidb_thumbnail/338316/individual_200.jpg?d=20190419162924&q=20" alt="[ステージオブマジック]島村卯月"> </a>
</td>
<td class=" " style="" data-col="1">
<a href="/[ステージオブマジック]島村卯月">
<span data-jscol_sort="[ステージオブマジック]島村卯月">[ステージオブマジック]島村卯月</span>
</a>
</td>
<td class=" " style="" data-col="2">
<span data-jscol_sort="島村卯月">
<a href="https://imascg-slstage-wiki.gamerch.com/%E5%B3%B6%E6%9D%91%E5%8D%AF%E6%9C%88" class="ui_page_match" title="島村卯月">
島村卯月
</a>
</span>
</td>
<td class=" " style="" data-col="3">
<span data-jscol_sort="キュート">キュート</span>
</td>
<td class=" " style="" data-col="4">
</td>
</tr>';
my $regex = qr/>([^<>]*\S)</mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}