# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((asia|europe|us|australia)|((north|south)(america|africa)))-((east|west|central|north|south)|((north|south)(east)))([0-9]{1,2})"
test_str = ("(east|west|central|north)?(north|south)?(east)[0-9]{1,2}\n"
"(east|west|central|north)(north|south)(east)[0-9]{1,2}\n\n"
"(north|south)(america)\n\n"
"FireStore Regions\n"
"us-west1 oregon\n"
"us-west2 Los Angeles\n"
"us-west3 Tuz Gölü şehri\n"
"us-west4 Las Vegas\n"
"northamerica-northeast1 Montreal\n"
"northafrica-west3\n"
"southafrica-east1\n"
"us-east1 Güney Carolina\n"
"us-east4 Kuzey Virginia\n"
"southamerica-east1 Sao Paulo\n"
"europe-west2 Londra\n"
"europe-west4\n"
"europe-west3 Frankfurt\n"
"europe-central2 Varşova\n"
"europe-west6 Zürih\n"
"asia-south1 Bombay\n"
"asia-southeast1 Singapur\n"
"asia-southeast2 Cakarta\n"
"asia-east2 Hong Kong\n"
"asia-east1 Tayvan\n"
"asia-northeast1 Tokyo\n"
"asia-northeast2 Osaka\n"
"asia-northeast3 Seul\n"
"australia-southeast1 Sidney\n"
"australia-southeast2\n\n"
"australia-southeast\n\n"
"Function Regions\n\n"
"asia-east1 (Tayvan)\n"
"asia-east2 (Hong Kong)\n"
"asia-northeast1 (Tokyo)\n"
"asia-northeast2 (Osaka)\n"
"europe-west1 (Belçika) \n"
"europe-west2 (Londra)\n"
"us-central1 (Iowa)\n"
"us-east1 (Güney Karolina)\n"
"us-east4 (Kuzey Virginia)\n"
"us-west1 (Oregon)\n"
"asia-northeast3 (Seul)\n"
"asia-southeast1 (Singapur)\n"
"asia-southeast2 (Cakarta)\n"
"asia-south1 (Mumbai)\n"
"australia-southeast1 (Sidney)\n"
"europe-central2 (Varşova)\n"
"europe-west3 (Frankfurt)\n"
"europe-west6 (Zürih) \n"
"northamerica-northeast1 (Montreal) \n"
"southamerica-east1 (Sao Paulo) \n"
"us-west2 (Los Angeles)\n"
"us-west3 (Salt Lake City)\n"
"us-west4 (Las Vegas)\n\n\n"
"asia-east1 (Tayvan) us-west2 (Los Angeles) europe-west1 (Belçika)\n"
"us-west3 (Salt Lake City) asia-northeast1 (Tokyo) southamerica-east1 (Sao Paulo)\n"
"us-west4 (Las Vegas) asia-east2 (Hong Kong) northamerica-northeast1 (Montreal)\n"
"europe-west2 (Londra) asia-south1 (Mumbai) europe-west3 (Frankfurt)\n"
"us-central1 (Iowa) europe-central2 (Varşova) europe-west6 (Zürih)\n"
"us-east1 (Güney Karolina)\n"
"asia-northeast3 (Seul)\n"
"us-east4 (Kuzey Virginia)\n"
"australia-southeast1 (Sidney)\n"
"us-west1 (Oregon)\n"
"asia-southeast2 (Cakarta)\n"
"asia-southeast1 (Singapur)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.