import Foundation
let pattern = #"((?=0*)[1-9]+[0-9]+\.{1}|0{1}\.{1})(?(1)(?!\.{2,})\d+)|(?=0*)([1-9]+[0-9]*(?!\.{2,}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123
000123
0.123
0.00123
0.00123000456
00000.00123000456
10000.00123000456
0..000000
123...456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)