$re = '/((?=0*)[1-9]+[0-9]+\.{1}|0{1}\.{1})(?(1)(?!\.{2,})\d+)|(?=0*)([1-9]+[0-9]*(?!\.{2,}))/m';
$str = '123
000123
0.123
0.00123
0.00123000456
00000.00123000456
10000.00123000456
0..000000
123...456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);