use strict;
my $str = '123
000123
0.123
0.00123
0.00123000456
00000.00123000456
10000.00123000456
0..000000
123...456
';
my $regex = qr/((?=0*)[1-9]+[0-9]+\.{1}|0{1}\.{1})(?(1)(?!\.{2,})\d+)|(?=0*)([1-9]+[0-9]*(?!\.{2,}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}