import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "jdbc:postgresql:(?=.)(?:(?:/$)|//(?:(?<user>[^:\\n\\r]+)(?::(?<pass>[^@\\n\\r]+))@)?(?<host>[^:/\\r\\n]+)(?::(?<port>\\d+))?/)?(?<db>.+)?";
final String string = "jdbc:postgresql:database\n"
+ "jdbc:postgresql:/\n"
+ "jdbc:postgresql://host/database\n"
+ "jdbc:postgresql://user:password@host/database\n"
+ "jdbc:postgresql://host/\n"
+ "jdbc:postgresql://host:1234/database\n"
+ "jdbc:postgresql://host:1234/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}