#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)jdbc:postgresql:(?=.)(?:(?:/$)|//(?:(?<user>[^:\n\r]+)(?::(?<pass>[^@\n\r]+))@)?(?<host>[^:/\r\n]+)(?::(?<port>\d+))?/)?(?<db>.+)?"
Local $sString = "jdbc:postgresql:database" & @CRLF & _
"jdbc:postgresql:/" & @CRLF & _
"jdbc:postgresql://host/database" & @CRLF & _
"jdbc:postgresql://user:password@host/database" & @CRLF & _
"jdbc:postgresql://host/" & @CRLF & _
"jdbc:postgresql://host:1234/database" & @CRLF & _
"jdbc:postgresql://host:1234/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")