import Foundation
let pattern = #"(http?.*rs=\d{6}&)(amp;)(rb=\d{7}&)(amp;)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://cdn.pvvstream.pro/videos/-184809347/456239491/vid_480p.mp4?rs=480000&rb=3728270&secure=8W7-Bh8jZNI_hhBBRfLeOg%3D%3D%2C1694789315"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)