$re = '/(http?.*rs=\d{6}&)(amp;)(rb=\d{7}&)(amp;)(.*)/m';
$str = 'https://cdn.pvvstream.pro/videos/-184809347/456239491/vid_480p.mp4?rs=480000&rb=3728270&secure=8W7-Bh8jZNI_hhBBRfLeOg%3D%3D%2C1694789315';
$subst = "$1$3$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;