using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http?.*rs=\d{6}&)(amp;)(rb=\d{7}&)(amp;)(.*)";
string substitution = @"$1$3$5";
string input = @"https://cdn.pvvstream.pro/videos/-184809347/456239491/vid_480p.mp4?rs=480000&rb=3728270&secure=8W7-Bh8jZNI_hhBBRfLeOg%3D%3D%2C1694789315";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}