#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?smx)" & @CRLF & _
"(?(DEFINE)" & @CRLF & _
" (?<jsonObject>" & @CRLF & _
" \{(?&jsonField)(?>,(?&jsonField))*+\}|" & @CRLF & _
" \{[[:space:]]*+\}" & @CRLF & _
" )" & @CRLF & _
" (?<jsonArray>" & @CRLF & _
" \[(?&jsonValue)(?>,(?&jsonValue))*+\]|" & @CRLF & _
" \[[[:space:]]*+\]" & @CRLF & _
" )" & @CRLF & _
" (?<string>" & @CRLF & _
" "" & @CRLF & _
" [^"\\]*+" & @CRLF & _
" (?>" & @CRLF & _
" (?>" & @CRLF & _
" \\["\\\/rntfb]|" & @CRLF & _
" \\u[[:xdigit:]]{4}" & @CRLF & _
" )++" & @CRLF & _
" [^"\\]*+" & @CRLF & _
" )*+" & @CRLF & _
" "" & @CRLF & _
" )" & @CRLF & _
" (?<number>" & @CRLF & _
" \-?+" & @CRLF & _
" (?>" & @CRLF & _
" [1-9][[:digit:]]*+|" & @CRLF & _
" 0" & @CRLF & _
" )" & @CRLF & _
" (?>\.[[:digit:]]++)?+" & @CRLF & _
" (?>[eE][\+\-]?+[[:digit:]]++)?+" & @CRLF & _
" )" & @CRLF & _
" (?<jsonValue>" & @CRLF & _
" [[:space:]]*+" & @CRLF & _
" (?>" & @CRLF & _
" (?&string)|" & @CRLF & _
" (?&number)|" & @CRLF & _
" (?&jsonObject)|" & @CRLF & _
" (?&jsonArray)|" & @CRLF & _
" false|" & @CRLF & _
" true|" & @CRLF & _
" null" & @CRLF & _
" )" & @CRLF & _
" [[:space:]]*+" & @CRLF & _
" )" & @CRLF & _
" (?<jsonField>" & @CRLF & _
" [[:space:]]*+(?&string)[[:space:]]*+\:" & @CRLF & _
" (?&jsonValue)" & @CRLF & _
" )" & @CRLF & _
")" & @CRLF & _
"^(?&jsonValue),\n"
Local $sString = "null," & @CRLF & _
" null," & @CRLF & _
"null ," & @CRLF & _
" null ," & @CRLF & _
"false," & @CRLF & _
" false," & @CRLF & _
"false ," & @CRLF & _
" false ," & @CRLF & _
"true," & @CRLF & _
" true," & @CRLF & _
"true ," & @CRLF & _
" true ," & @CRLF & _
"123," & @CRLF & _
"0," & @CRLF & _
"-123," & @CRLF & _
"-0," & @CRLF & _
"123.0," & @CRLF & _
"0.0," & @CRLF & _
"-123.0," & @CRLF & _
"-0.0," & @CRLF & _
"123e1," & @CRLF & _
"0e1," & @CRLF & _
"-123e1," & @CRLF & _
"-0e1," & @CRLF & _
"123.0e1," & @CRLF & _
"0.0e1," & @CRLF & _
"-123.0e1," & @CRLF & _
"-0.0e1," & @CRLF & _
"123e+1," & @CRLF & _
"0e+1," & @CRLF & _
"-123e+1," & @CRLF & _
"-0e+1," & @CRLF & _
"123.0e+1," & @CRLF & _
"0.0e+1," & @CRLF & _
"-123.0e+1," & @CRLF & _
"-0.0e+1," & @CRLF & _
"123e-1," & @CRLF & _
"0e-1," & @CRLF & _
"-123e-1," & @CRLF & _
"-0e-1," & @CRLF & _
"123.0e-1," & @CRLF & _
"0.0e-1," & @CRLF & _
"-123.0e-1," & @CRLF & _
"-0.0e-1," & @CRLF & _
"123E1," & @CRLF & _
"0E1," & @CRLF & _
"-123E1," & @CRLF & _
"-0E1," & @CRLF & _
"123.0E1," & @CRLF & _
"0.0E1," & @CRLF & _
"-123.0E1," & @CRLF & _
"-0.0E1," & @CRLF & _
"123E+1," & @CRLF & _
"0E+1," & @CRLF & _
"-123E+1," & @CRLF & _
"-0E+1," & @CRLF & _
"123.0E+1," & @CRLF & _
"0.0E+1," & @CRLF & _
"-123.0E+1," & @CRLF & _
"-0.0E+1," & @CRLF & _
"123E-1," & @CRLF & _
"0E-1," & @CRLF & _
"-123E-1," & @CRLF & _
"-0E-1," & @CRLF & _
"123.0E-1," & @CRLF & _
"0.0E-1," & @CRLF & _
"-123.0E-1," & @CRLF & _
"-0.0E-1," & @CRLF & _
" 123," & @CRLF & _
" 0," & @CRLF & _
" -123," & @CRLF & _
" -0," & @CRLF & _
" 123.0," & @CRLF & _
" 0.0," & @CRLF & _
" -123.0," & @CRLF & _
" -0.0," & @CRLF & _
" 123e1," & @CRLF & _
" 0e1," & @CRLF & _
" -123e1," & @CRLF & _
" -0e1," & @CRLF & _
" 123.0e1," & @CRLF & _
" 0.0e1," & @CRLF & _
" -123.0e1," & @CRLF & _
" -0.0e1," & @CRLF & _
" 123e+1," & @CRLF & _
" 0e+1," & @CRLF & _
" -123e+1," & @CRLF & _
" -0e+1," & @CRLF & _
" 123.0e+1," & @CRLF & _
" 0.0e+1," & @CRLF & _
" -123.0e+1," & @CRLF & _
" -0.0e+1," & @CRLF & _
" 123e-1," & @CRLF & _
" 0e-1," & @CRLF & _
" -123e-1," & @CRLF & _
" -0e-1," & @CRLF & _
" 123.0e-1," & @CRLF & _
" 0.0e-1," & @CRLF & _
" -123.0e-1," & @CRLF & _
" -0.0e-1," & @CRLF & _
" 123E1," & @CRLF & _
" 0E1," & @CRLF & _
" -123E1," & @CRLF & _
" -0E1," & @CRLF & _
" 123.0E1," & @CRLF & _
" 0.0E1," & @CRLF & _
" -123.0E1," & @CRLF & _
" -0.0E1," & @CRLF & _
" 123E+1," & @CRLF & _
" 0E+1," & @CRLF & _
" -123E+1," & @CRLF & _
" -0E+1," & @CRLF & _
" 123.0E+1," & @CRLF & _
" 0.0E+1," & @CRLF & _
" -123.0E+1," & @CRLF & _
" -0.0E+1," & @CRLF & _
" 123E-1," & @CRLF & _
" 0E-1," & @CRLF & _
" -123E-1," & @CRLF & _
" -0E-1," & @CRLF & _
" 123.0E-1," & @CRLF & _
" 0.0E-1," & @CRLF & _
" -123.0E-1," & @CRLF & _
" -0.0E-1," & @CRLF & _
"123 ," & @CRLF & _
"0 ," & @CRLF & _
"-123 ," & @CRLF & _
"-0 ," & @CRLF & _
"123.0 ," & @CRLF & _
"0.0 ," & @CRLF & _
"-123.0 ," & @CRLF & _
"-0.0 ," & @CRLF & _
"123e1 ," & @CRLF & _
"0e1 ," & @CRLF & _
"-123e1 ," & @CRLF & _
"-0e1 ," & @CRLF & _
"123.0e1 ," & @CRLF & _
"0.0e1 ," & @CRLF & _
"-123.0e1 ," & @CRLF & _
"-0.0e1 ," & @CRLF & _
"123e+1 ," & @CRLF & _
"0e+1 ," & @CRLF & _
"-123e+1 ," & @CRLF & _
"-0e+1 ," & @CRLF & _
"123.0e+1 ," & @CRLF & _
"0.0e+1 ," & @CRLF & _
"-123.0e+1 ," & @CRLF & _
"-0.0e+1 ," & @CRLF & _
"123e-1 ," & @CRLF & _
"0e-1 ," & @CRLF & _
"-123e-1 ," & @CRLF & _
"-0e-1 ," & @CRLF & _
"123.0e-1 ," & @CRLF & _
"0.0e-1 ," & @CRLF & _
"-123.0e-1 ," & @CRLF & _
"-0.0e-1 ," & @CRLF & _
"123E1 ," & @CRLF & _
"0E1 ," & @CRLF & _
"-123E1 ," & @CRLF & _
"-0E1 ," & @CRLF & _
"123.0E1 ," & @CRLF & _
"0.0E1 ," & @CRLF & _
"-123.0E1 ," & @CRLF & _
"-0.0E1 ," & @CRLF & _
"123E+1 ," & @CRLF & _
"0E+1 ," & @CRLF & _
"-123E+1 ," & @CRLF & _
"-0E+1 ," & @CRLF & _
"123.0E+1 ," & @CRLF & _
"0.0E+1 ," & @CRLF & _
"-123.0E+1 ," & @CRLF & _
"-0.0E+1 ," & @CRLF & _
"123E-1 ," & @CRLF & _
"0E-1 ," & @CRLF & _
"-123E-1 ," & @CRLF & _
"-0E-1 ," & @CRLF & _
"123.0E-1 ," & @CRLF & _
"0.0E-1 ," & @CRLF & _
"-123.0E-1 ," & @CRLF & _
"-0.0E-1 ," & @CRLF & _
" 123 ," & @CRLF & _
" 0 ," & @CRLF & _
" -123 ," & @CRLF & _
" -0 ," & @CRLF & _
" 123.0 ," & @CRLF & _
" 0.0 ," & @CRLF & _
" -123.0 ," & @CRLF & _
" -0.0 ," & @CRLF & _
" 123e1 ," & @CRLF & _
" 0e1 ," & @CRLF & _
" -123e1 ," & @CRLF & _
" -0e1 ," & @CRLF & _
" 123.0e1 ," & @CRLF & _
" 0.0e1 ," & @CRLF & _
" -123.0e1 ," & @CRLF & _
" -0.0e1 ," & @CRLF & _
" 123e+1 ," & @CRLF & _
" 0e+1 ," & @CRLF & _
" -123e+1 ," & @CRLF & _
" -0e+1 ," & @CRLF & _
" 123.0e+1 ," & @CRLF & _
" 0.0e+1 ," & @CRLF & _
" -123.0e+1 ," & @CRLF & _
" -0.0e+1 ," & @CRLF & _
" 123e-1 ," & @CRLF & _
" 0e-1 ," & @CRLF & _
" -123e-1 ," & @CRLF & _
" -0e-1 ," & @CRLF & _
" 123.0e-1 ," & @CRLF & _
" 0.0e-1 ," & @CRLF & _
" -123.0e-1 ," & @CRLF & _
" -0.0e-1 ," & @CRLF & _
" 123E1 ," & @CRLF & _
" 0E1 ," & @CRLF & _
" -123E1 ," & @CRLF & _
" -0E1 ," & @CRLF & _
" 123.0E1 ," & @CRLF & _
" 0.0E1 ," & @CRLF & _
" -123.0E1 ," & @CRLF & _
" -0.0E1 ," & @CRLF & _
" 123E+1 ," & @CRLF & _
" 0E+1 ," & @CRLF & _
" -123E+1 ," & @CRLF & _
" -0E+1 ," & @CRLF & _
" 123.0E+1 ," & @CRLF & _
" 0.0E+1 ," & @CRLF & _
" -123.0E+1 ," & @CRLF & _
" -0.0E+1 ," & @CRLF & _
" 123E-1 ," & @CRLF & _
" 0E-1 ," & @CRLF & _
" -123E-1 ," & @CRLF & _
" -0E-1 ," & @CRLF & _
" 123.0E-1 ," & @CRLF & _
" 0.0E-1 ," & @CRLF & _
" -123.0E-1 ," & @CRLF & _
" -0.0E-1 ," & @CRLF & _
"""," & @CRLF & _
""zyxwvuts"," & @CRLF & _
""\\\/\r\n\t\f\b"," & @CRLF & _
""\u1234\uabcd\uABCD"," & @CRLF & _
""zyxwvutszyxwvuts"," & @CRLF & _
""zyxwvuts\\\/\r\n\t\f\b"," & @CRLF & _
""zyxwvuts\u1234\uabcd\uABCD"," & @CRLF & _
""\\\/\r\n\t\f\bzyxwvuts"," & @CRLF & _
""\\\/\r\n\t\f\b\\\/\r\n\t\f\b"," & @CRLF & _
""\\\/\r\n\t\f\b\u1234\uabcd\uABCD"," & @CRLF & _
""\u1234\uabcd\uABCDzyxwvuts"," & @CRLF & _
""\u1234\uabcd\uABCD\\\/\r\n\t\f\b"," & @CRLF & _
""\u1234\uabcd\uABCD\u1234\uabcd\uABCD"," & @CRLF & _
""zyxwvutszyxwvutszyxwvuts"," & @CRLF & _
""zyxwvuts\\\/\r\n\t\f\bzyxwvuts"," & @CRLF & _
""zyxwvuts\u1234\uabcd\uABCDzyxwvuts"," & @CRLF & _
""\\\/\r\n\t\f\bzyxwvutszyxwvuts"," & @CRLF & _
""\\\/\r\n\t\f\b\\\/\r\n\t\f\bzyxwvuts"," & @CRLF & _
""\\\/\r\n\t\f\b\u1234\uabcd\uABCDzyxwvuts"," & @CRLF & _
""\u1234\uabcd\uABCDzyxwvutszyxwvuts"," & @CRLF & _
""\u1234\uabcd\uABCD\\\/\r\n\t\f\bzyxwvuts"," & @CRLF & _
""\u1234\uabcd\uABCD\u1234\uabcd\uABCDzyxwvuts"," & @CRLF & _
""zyxwvutszyxwvuts\\\/\r\n\t\f\b"," & @CRLF & _
""zyxwvuts\\\/\r\n\t\f\b\\\/\r\n\t\f\b"," & @CRLF & _
""zyxwvuts\u1234\uabcd\uABCD\\\/\r\n\t\f\b"," & @CRLF & _
""\\\/\r\n\t\f\bzyxwvuts\\\/\r\n\t\f\b"," & @CRLF & _
""\\\/\r\n\t\f\b\\\/\r\n\t\f\b\\\/\r\n\t\f\b"," & @CRLF & _
""\\\/\r\n\t\f\b\u1234\uabcd\uABCD\\\/\r\n\t\f\b"," & @CRLF & _
""\u1234\uabcd\uABCDzyxwvuts\\\/\r\n\t\f\b"," & @CRLF & _
""\u1234\uabcd\uABCD\\\/\r\n\t\f\b\\\/\r\n\t\f\b"," & @CRLF & _
""\u1234\uabcd\uABCD\u1234\uabcd\uABCD\\\/\r\n\t\f\b"," & @CRLF & _
""zyxwvutszyxwvuts\u1234\uabcd\uABCD"," & @CRLF & _
""zyxwvuts\\\/\r\n\t\f\b\u1234\uabcd\uABCD"," & @CRLF & _
""zyxwvuts\u1234\uabcd\uABCD\u1234\uabcd\uABCD"," & @CRLF & _
""\\\/\r\n\t\f\bzyxwvuts\u1234\uabcd\uABCD"," & @CRLF & _
""\\\/\r\n\t\f\b\\\/\r\n\t\f\b\u1234\uabcd\uABCD"," & @CRLF & _
""\\\/\r\n\t\f\b\u1234\uabcd\uABCD\u1234\uabcd\uABCD"," & @CRLF & _
""\u1234\uabcd\uABCDzyxwvuts\u1234\uabcd\uABCD"," & @CRLF & _
""\u1234\uabcd\uABCD\\\/\r\n\t\f\b\u1234\uabcd\uABCD"," & @CRLF & _
""\u1234\uabcd\uABCD\u1234\uabcd\uABCD\u1234\uabcd\uABCD"," & @CRLF & _
" ""," & @CRLF & _
" "zyxwvuts"," & @CRLF & _
" "\\\/\r\n\t\f\b"," & @CRLF & _
" "\u1234\uabcd\uABCD"," & @CRLF & _
" "zyxwvutszyxwvuts"," & @CRLF & _
" "zyxwvuts\\\/\r\n\t\f\b"," & @CRLF & _
" "zyxwvuts\u1234\uabcd\uABCD"," & @CRLF & _
" "\\\/\r\n\t\f\bzyxwvuts"," & @CRLF & _
" "\\\/\r\n\t\f\b\\\/\r\n\t\f\b"," & @CRLF & _
" "\\\/\r\n\t\f\b\u1234\uabcd\uABCD"," & @CRLF & _
" "\u1234\uabcd\uABCDzyxwvuts"," & @CRLF & _
" "\u1234\uabcd\uABCD\\\/\r\n\t\f\b"," & @CRLF & _
" "\u1234\uabcd\uABCD\u1234\uabcd\uABCD"," & @CRLF & _
" "zyxwvutszyxwvutszyxwvuts"," & @CRLF & _
" "zyxwvuts\\\/\r\n\t\f\bzyxwvuts"," & @CRLF & _
" "zyxwvuts\u1234\uabcd\uABCDzyxwvuts"," & @CRLF & _
" "\\\/\r\n\t\f\bzyxwvutszyxwvuts"," & @CRLF & _
" "\\\/\r\n\t\f\b\\\/\r\n\t\f\bzyxwvuts"," & @CRLF & _
" "\\\/\r\n\t\f\b\u1234\uabcd\uABCDzyxwvuts"," & @CRLF & _
" "\u1234\uabcd\uABCDzyxwvutszyxwvuts"," & @CRLF & _
" "\u1234\uabcd\uABCD\\\/\r\n\t\f\bzyxwvuts"," & @CRLF & _
" "\u1234\uabcd\uABCD\u1234\uabcd\uABCDzyxwvuts"," & @CRLF & _
" "zyxwvutszyxwvuts\\\/\r\n\t\f\b"," & @CRLF & _
" "zyxwvuts\\\/\r\n\t\f\b\\\/\r\n\t\f\b"," & @CRLF & _
" "zyxwvuts\u1234\uabcd\uABCD\\\/\r\n\t\f\b"," & @CRLF & _
" "\\\/\r\n\t\f\bzyxwvuts\\\/\r\n\t\f\b"," & @CRLF & _
" "\\\/\r\n\t\f\b\\\/\r\n\t\f\b\\\/\r\n\t\f\b"," & @CRLF & _
" "\\\/\r\n\t\f\b\u1234\uabcd\uABCD\\\/\r\n\t\f\b"," & @CRLF & _
" "\u1234\uabcd\uABCDzyxwvuts\\\/\r\n\t\f\b"," & @CRLF & _
" "\u1234\uabcd\uABCD\\\/\r\n\t\f\b\\\/\r\n\t\f\b"," & @CRLF & _
" "\u1234\uabcd\uABCD\u1234\uabcd\uABCD\\\/\r\n\t\f\b"," & @CRLF & _
" "zyxwvutszyxwvuts\u1234\uabcd\uABCD"," & @CRLF & _
" "zyxwvuts\\\/\r\n\t\f\b\u1234\uabcd\uABCD"," & @CRLF & _
" "zyxwvuts\u1234\uabcd\uABCD\u1234\uabcd\uABCD"," & @CRLF & _
" "\\\/\r\n\t\f\bzyxwvuts\u1234\uabcd\uABCD"," & @CRLF & _
" "\\\/\r\n\t\f\b\\\/\r\n\t\f\b\u1234\uabcd\uABCD"," & @CRLF & _
" "\\\/\r\n\t\f\b\u1234\uabcd\uABCD\u1234\uabcd\uABCD"," & @CRLF & _
" "\u1234\uabcd\uABCDzyxwvuts\u1234\uabcd\uABCD"," & @CRLF & _
" "\u1234\uabcd\uABCD\\\/\r\n\t\f\b\u1234\uabcd\uABCD"," & @CRLF & _
" "\u1234\uabcd\uABCD\u1234\uabcd\uABCD\u1234\uabcd\uABCD"," & @CRLF & _
""" ," & @CRLF & _
""zyxwvuts" ," & @CRLF & _
""\\\/\r\n\t\f\b" ," & @CRLF & _
""\u1234\uabcd\uABCD" ," & @CRLF & _
""zyxwvutszyxwvuts" ," & @CRLF & _
""zyxwvuts\\\/\r\n\t\f\b" ," & @CRLF & _
""zyxwvuts\u1234\uabcd\uABCD" ," & @CRLF & _
""\\\/\r\n\t\f\bzyxwvuts" ," & @CRLF & _
""\\\/\r\n\t\f\b\\\/\r\n\t\f\b" ," & @CRLF & _
""\\\/\r\n\t\f\b\u1234\uabcd\uABCD" ," & @CRLF & _
""\u1234\uabcd\uABCDzyxwvuts" ," & @CRLF & _
""\u1234\uabcd\uABCD\\\/\r\n\t\f\b" ," & @CRLF & _
""\u1234\uabcd\uABCD\u1234\uabcd\uABCD" ," & @CRLF & _
""zyxwvutszyxwvutszyxwvuts" ," & @CRLF & _
""zyxwvuts\\\/\r\n\t\f\bzyxwvuts" ," & @CRLF & _
""zyxwvuts\u1234\uabcd\uABCDzyxwvuts" ," & @CRLF & _
""\\\/\r\n\t\f\bzyxwvutszyxwvuts" ," & @CRLF & _
""\\\/\r\n\t\f\b\\\/\r\n\t\f\bzyxwvuts" ," & @CRLF & _
""\\\/\r\n\t\f\b\u1234\uabcd\uABCDzyxwvuts" ," & @CRLF & _
""\u1234\uabcd\uABCDzyxwvutszyxwvuts" ," & @CRLF & _
""\u1234\uabcd\uABCD\\\/\r\n\t\f\bzyxwvuts" ," & @CRLF & _
""\u1234\uabcd\uABCD\u1234\uabcd\uABCDzyxwvuts" ," & @CRLF & _
""zyxwvutszyxwvuts\\\/\r\n\t\f\b" ," & @CRLF & _
""zyxwvuts\\\/\r\n\t\f\b\\\/\r\n\t\f\b" ," & @CRLF & _
""zyxwvuts\u1234\uabcd\uABCD\\\/\r\n\t\f\b" ," & @CRLF & _
""\\\/\r\n\t\f\bzyxwvuts\\\/\r\n\t\f\b" ," & @CRLF & _
""\\\/\r\n\t\f\b\\\/\r\n\t\f\b\\\/\r\n\t\f\b" ," & @CRLF & _
""\\\/\r\n\t\f\b\u1234\uabcd\uABCD\\\/\r\n\t\f\b" ," & @CRLF & _
""\u1234\uabcd\uABCDzyxwvuts\\\/\r\n\t\f\b" ," & @CRLF & _
""\u1234\uabcd\uABCD\\\/\r\n\t\f\b\\\/\r\n\t\f\b" ," & @CRLF & _
""\u1234\uabcd\uABCD\u1234\uabcd\uABCD\\\/\r\n\t\f\b" ," & @CRLF & _
""zyxwvutszyxwvuts\u1234\uabcd\uABCD" ," & @CRLF & _
""zyxwvuts\\\/\r\n\t\f\b\u1234\uabcd\uABCD" ," & @CRLF & _
""zyxwvuts\u1234\uabcd\uABCD\u1234\uabcd\uABCD" ," & @CRLF & _
""\\\/\r\n\t\f\bzyxwvuts\u1234\uabcd\uABCD" ," & @CRLF & _
""\\\/\r\n\t\f\b\\\/\r\n\t\f\b\u1234\uabcd\uABCD" ," & @CRLF & _
""\\\/\r\n\t\f\b\u1234\uabcd\uABCD\u1234\uabcd\uABCD" ," & @CRLF & _
""\u1234\uabcd\uABCDzyxwvuts\u1234\uabcd\uABCD" ," & @CRLF & _
""\u1234\uabcd\uABCD\\\/\r\n\t\f\b\u1234\uabcd\uABCD" ," & @CRLF & _
""\u1234\uabcd\uABCD\u1234\uabcd\uABCD\u1234\uabcd\uABCD" ," & @CRLF & _
" "" ," & @CRLF & _
" "zyxwvuts" ," & @CRLF & _
" "\\\/\r\n\t\f\b" ," & @CRLF & _
" "\u1234\uabcd\uABCD" ," & @CRLF & _
" "zyxwvutszyxwvuts" ," & @CRLF & _
" "zyxwvuts\\\/\r\n\t\f\b" ," & @CRLF & _
" "zyxwvuts\u1234\uabcd\uABCD" ," & @CRLF & _
" "\\\/\r\n\t\f\bzyxwvuts" ," & @CRLF & _
" "\\\/\r\n\t\f\b\\\/\r\n\t\f\b" ," & @CRLF & _
" "\\\/\r\n\t\f\b\u1234\uabcd\uABCD" ," & @CRLF & _
" "\u1234\uabcd\uABCDzyxwvuts" ," & @CRLF & _
" "\u1234\uabcd\uABCD\\\/\r\n\t\f\b" ," & @CRLF & _
" "\u1234\uabcd\uABCD\u1234\uabcd\uABCD" ," & @CRLF & _
" "zyxwvutszyxwvutszyxwvuts" ," & @CRLF & _
" "zyxwvuts\\\/\r\n\t\f\bzyxwvuts" ," & @CRLF & _
" "zyxwvuts\u1234\uabcd\uABCDzyxwvuts" ," & @CRLF & _
" "\\\/\r\n\t\f\bzyxwvutszyxwvuts" ," & @CRLF & _
" "\\\/\r\n\t\f\b\\\/\r\n\t\f\bzyxwvuts" ," & @CRLF & _
" "\\\/\r\n\t\f\b\u1234\uabcd\uABCDzyxwvuts" ," & @CRLF & _
" "\u1234\uabcd\uABCDzyxwvutszyxwvuts" ," & @CRLF & _
" "\u1234\uabcd\uABCD\\\/\r\n\t\f\bzyxwvuts" ," & @CRLF & _
" "\u1234\uabcd\uABCD\u1234\uabcd\uABCDzyxwvuts" ," & @CRLF & _
" "zyxwvutszyxwvuts\\\/\r\n\t\f\b" ," & @CRLF & _
" "zyxwvuts\\\/\r\n\t\f\b\\\/\r\n\t\f\b" ," & @CRLF & _
" "zyxwvuts\u1234\uabcd\uABCD\\\/\r\n\t\f\b" ," & @CRLF & _
" "\\\/\r\n\t\f\bzyxwvuts\\\/\r\n\t\f\b" ," & @CRLF & _
" "\\\/\r\n\t\f\b\\\/\r\n\t\f\b\\\/\r\n\t\f\b" ," & @CRLF & _
" "\\\/\r\n\t\f\b\u1234\uabcd\uABCD\\\/\r\n\t\f\b" ," & @CRLF & _
" "\u1234\uabcd\uABCDzyxwvuts\\\/\r\n\t\f\b" ," & @CRLF & _
" "\u1234\uabcd\uABCD\\\/\r\n\t\f\b\\\/\r\n\t\f\b" ," & @CRLF & _
" "\u1234\uabcd\uABCD\u1234\uabcd\uABCD\\\/\r\n\t\f\b" ," & @CRLF & _
" "zyxwvutszyxwvuts\u1234\uabcd\uABCD" ," & @CRLF & _
" "zyxwvuts\\\/\r\n\t\f\b\u1234\uabcd\uABCD" ," & @CRLF & _
" "zyxwvuts\u1234\uabcd\uABCD\u1234\uabcd\uABCD" ," & @CRLF & _
" "\\\/\r\n\t\f\bzyxwvuts\u1234\uabcd\uABCD" ," & @CRLF & _
" "\\\/\r\n\t\f\b\\\/\r\n\t\f\b\u1234\uabcd\uABCD" ," & @CRLF & _
" "\\\/\r\n\t\f\b\u1234\uabcd\uABCD\u1234\uabcd\uABCD" ," & @CRLF & _
" "\u1234\uabcd\uABCDzyxwvuts\u1234\uabcd\uABCD" ," & @CRLF & _
" "\u1234\uabcd\uABCD\\\/\r\n\t\f\b\u1234\uabcd\uABCD" ," & @CRLF & _
" "\u1234\uabcd\uABCD\u1234\uabcd\uABCD\u1234\uabcd\uABCD" ," & @CRLF & _
"{}," & @CRLF & _
"{ }," & @CRLF & _
"{"1":1}," & @CRLF & _
"{ "1" : 1 }," & @CRLF & _
"{"1":1,"2":2}," & @CRLF & _
"{ "1" : 1, "2" : 2 }," & @CRLF & _
" {}," & @CRLF & _
" { }," & @CRLF & _
" {"1":1}," & @CRLF & _
" { "1" : 1 }," & @CRLF & _
" {"1":1,"2":2}," & @CRLF & _
" { "1" : 1, "2" : 2 }," & @CRLF & _
"{} ," & @CRLF & _
"{ } ," & @CRLF & _
"{"1":1} ," & @CRLF & _
"{ "1" : 1 } ," & @CRLF & _
"{"1":1,"2":2} ," & @CRLF & _
"{ "1" : 1, "2" : 2 } ," & @CRLF & _
" {} ," & @CRLF & _
" { } ," & @CRLF & _
" {"1":1} ," & @CRLF & _
" { "1" : 1 } ," & @CRLF & _
" {"1":1,"2":2} ," & @CRLF & _
" { "1" : 1, "2" : 2 } ," & @CRLF & _
"[]," & @CRLF & _
"[ ]," & @CRLF & _
"[1]," & @CRLF & _
"[ 1 ]," & @CRLF & _
"[1,2]," & @CRLF & _
"[ 1, 2 ]," & @CRLF & _
" []," & @CRLF & _
" [ ]," & @CRLF & _
" [1]," & @CRLF & _
" [ 1 ]," & @CRLF & _
" [1,2]," & @CRLF & _
" [ 1, 2 ]," & @CRLF & _
"[] ," & @CRLF & _
"[ ] ," & @CRLF & _
"[1] ," & @CRLF & _
"[ 1 ] ," & @CRLF & _
"[1,2] ," & @CRLF & _
"[ 1, 2 ] ," & @CRLF & _
" [] ," & @CRLF & _
" [ ] ," & @CRLF & _
" [1] ," & @CRLF & _
" [ 1 ] ," & @CRLF & _
" [1,2] ," & @CRLF & _
" [ 1, 2 ] ," & @CRLF & _
"{"x":{}}," & @CRLF & _
"{"x":[]}," & @CRLF & _
"{ "x" : {} }," & @CRLF & _
"{ "x" : [] }," & @CRLF & _
"[{}]," & @CRLF & _
"[[]]," & @CRLF & _
"[ { } ]," & @CRLF & _
"[ [ ] ]," & @CRLF & _
" {"x":{}}," & @CRLF & _
" {"x":[]}," & @CRLF & _
" { "x" : {} }," & @CRLF & _
" { "x" : [] }," & @CRLF & _
" [{}]," & @CRLF & _
" [[]]," & @CRLF & _
" [ { } ]," & @CRLF & _
" [ [ ] ]," & @CRLF & _
"{"x":{}} ," & @CRLF & _
"{"x":[]} ," & @CRLF & _
"{ "x" : {} } ," & @CRLF & _
"{ "x" : [] } ," & @CRLF & _
"[{}] ," & @CRLF & _
"[[]] ," & @CRLF & _
"[ { } ] ," & @CRLF & _
"[ [ ] ] ," & @CRLF & _
" {"x":{}} ," & @CRLF & _
" {"x":[]} ," & @CRLF & _
" { "x" : {} } ," & @CRLF & _
" { "x" : [] } ," & @CRLF & _
" [{}] ," & @CRLF & _
" [[]] ," & @CRLF & _
" [ { } ] ," & @CRLF & _
" [ [ ] ] ," & @CRLF & _
"" & @CRLF & _
"#values to NOT match" & @CRLF & _
"Null," & @CRLF & _
"False," & @CRLF & _
"True," & @CRLF & _
"01," & @CRLF & _
"+1," & @CRLF & _
"1.," & @CRLF & _
"" " "," & @CRLF & _
"" \ "," & @CRLF & _
"" \x "," & @CRLF & _
"""x," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")