$re = '/^[0-9]{9}[vVxX]$/';
$str = '958745896V';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);