using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^0-9a-zA-Z|\\/ !#$%^&*()[{}\]:<>?_\\]+";
string input = @"qwertyuiop
asdfghjkl;'
zxcvbnm,.;/
QWERTYUIOP
ASDFGHJKL:""'
ZXCVBNM<>?/
1234567890
!@#$%^&*()_-[]{}s
|\,./asdf
=+-@
,;'""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}