re = /(?!([^\u3000-\u303f\u3040-\u309f\u30a0-\u30ff\uff00-\uff9f\u4e00-\u9faf\u3400-\u4dbf]|[ ])).+(?<!([^\u3000-\u303f\u3040-\u309f\u30a0-\u30ff\uff00-\uff9f\u4e00-\u9faf\u3400-\u4dbf]|[ ]))/m
str = 'this qwhaisdii iaidaisdiqwhehqewi 前に来た時は北側からで、当時の光景はいまでも思い出せる。asdqweqweqweasdd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end