// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<img (.*? )*?src=")([^:]*?)"\/"#).unwrap();
let string = "<img bla=\"blubb\" src=\"/foo\"/>lalala</img>text<img bla=\"blubb\" src=\"p://foo\"/>lalala</img>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}