$re = '/(<img (.*? )*?src=")([^:]*?)"\//';
$str = '<img bla="blubb" src="/foo"/>lalala</img>text<img bla="blubb" src="p://foo"/>lalala</img>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);