package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<img (.*? )*?src=")([^:]*?)"\/`)
var str = `<img bla="blubb" src="/foo"/>lalala</img>text<img bla="blubb" src="p://foo"/>lalala</img>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}