using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img (.*? )*?src="")([^:]*?)""\/";
string input = @"<img bla=""blubb"" src=""/foo""/>lalala</img>text<img bla=""blubb"" src=""p://foo""/>lalala</img>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}