using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?i)(((ldap|ldap):\/\/){0,1})((?i)(ou|cn)=(([a-zA-Z0-9]|[-]|[_])){1,63},)+((?i)(dc=)(([a-zA-Z0-9]|[-]|[_])){1,63},){1,2}(?i)(dc=)(([a-zA-Z0-9]){2,63})$";
string input = @"CN=users,DC=example,DC=com
OU=mailgroups,OU=People,OU=organisation,DC=example,DC=at
LDAP://OU=mailgroups,OU=People,OU=organisation,DC=example,DC=at";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}