const regex = /(\d{4}\x2f\d{2}\x2f\d{2}\s+\d{2}\x3a\d{2}\x3a\d{2})\x2e\d+\s+(\w+\x2b\d+\x3a\d+)\s+(\d{2}\x2e\d{3}\x2e\d{2}\x2e\d{3})\s+(\w{3}\s+\d+\s+\d{2}\x3a\d{2}\x3a\d{2})\s+(\w+\x2e\w+\x2e\w+\x2e\w+\x2e\w+)\s+(\d\x3b\d\x3b\w+\x2d\w+\x2d\w+\x2d\w+\x2d\w+)\x3b(\d+\x2d\d+\x2d\d+\x2d\d+\x2d\d+)\x3b\x22\d+\x3a\s+(\w+)\x3a\s+(\w+\s+\w+\s+\w+\s+\w+\s+\w+)\x22\x3b(\d+)\x3b\x22(\w+)\x22\x3b(\d{2}\x2e\d{3}\x2e\d{3}\x2e\d{3})\x3b(\d+)\x3b(\d{3}\x2e\d{3}\x2e\d{2}\x2e\d{3})\x3b(\d+)\x3b\d\x3b\d\w\x3b\d\w\x3b\d\x3b\d+\x3b\x22(\w+)\x22\x3b\d+\x3b\d+\x3b\s+\x3b\d+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4}\\x2f\\d{2}\\x2f\\d{2}\\s+\\d{2}\\x3a\\d{2}\\x3a\\d{2})\\x2e\\d+\\s+(\\w+\\x2b\\d+\\x3a\\d+)\\s+(\\d{2}\\x2e\\d{3}\\x2e\\d{2}\\x2e\\d{3})\\s+(\\w{3}\\s+\\d+\\s+\\d{2}\\x3a\\d{2}\\x3a\\d{2})\\s+(\\w+\\x2e\\w+\\x2e\\w+\\x2e\\w+\\x2e\\w+)\\s+(\\d\\x3b\\d\\x3b\\w+\\x2d\\w+\\x2d\\w+\\x2d\\w+\\x2d\\w+)\\x3b(\\d+\\x2d\\d+\\x2d\\d+\\x2d\\d+\\x2d\\d+)\\x3b\\x22\\d+\\x3a\\s+(\\w+)\\x3a\\s+(\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\w+)\\x22\\x3b(\\d+)\\x3b\\x22(\\w+)\\x22\\x3b(\\d{2}\\x2e\\d{3}\\x2e\\d{3}\\x2e\\d{3})\\x3b(\\d+)\\x3b(\\d{3}\\x2e\\d{3}\\x2e\\d{2}\\x2e\\d{3})\\x3b(\\d+)\\x3b\\d\\x3b\\d\\w\\x3b\\d\\w\\x3b\\d\\x3b\\d+\\x3b\\x22(\\w+)\\x22\\x3b\\d+\\x3b\\d+\\x3b\\s+\\x3b\\d+', '')
const str = `2015/07/25 17:26:16.028 GMT+08:00 10.100.10.222 May 16 17:29:29 nipssmsdc2.hqlan.abc.com.my 8;3;92439f8d-86fa-4522-aeea-42e250b0fa05;00000001-0001-0001-0001-000000013012;"13012: SIP: SipVicious Brute Force SIP Tool";13012;"udp";62.210.248.238;5084;202.190.48.185;6060;1;4A;4B;7;11;"nips02dc1";16929789;1431768569067; ;95128847`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}