using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4}\x2f\d{2}\x2f\d{2}\s+\d{2}\x3a\d{2}\x3a\d{2})\x2e\d+\s+(\w+\x2b\d+\x3a\d+)\s+(\d{2}\x2e\d{3}\x2e\d{2}\x2e\d{3})\s+(\w{3}\s+\d+\s+\d{2}\x3a\d{2}\x3a\d{2})\s+(\w+\x2e\w+\x2e\w+\x2e\w+\x2e\w+)\s+(\d\x3b\d\x3b\w+\x2d\w+\x2d\w+\x2d\w+\x2d\w+)\x3b(\d+\x2d\d+\x2d\d+\x2d\d+\x2d\d+)\x3b\x22\d+\x3a\s+(\w+)\x3a\s+(\w+\s+\w+\s+\w+\s+\w+\s+\w+)\x22\x3b(\d+)\x3b\x22(\w+)\x22\x3b(\d{2}\x2e\d{3}\x2e\d{3}\x2e\d{3})\x3b(\d+)\x3b(\d{3}\x2e\d{3}\x2e\d{2}\x2e\d{3})\x3b(\d+)\x3b\d\x3b\d\w\x3b\d\w\x3b\d\x3b\d+\x3b\x22(\w+)\x22\x3b\d+\x3b\d+\x3b\s+\x3b\d+";
string input = @"2015/07/25 17:26:16.028 GMT+08:00 10.100.10.222 May 16 17:29:29 nipssmsdc2.hqlan.abc.com.my 8;3;92439f8d-86fa-4522-aeea-42e250b0fa05;00000001-0001-0001-0001-000000013012;""13012: SIP: SipVicious Brute Force SIP Tool"";13012;""udp"";62.210.248.238;5084;202.190.48.185;6060;1;4A;4B;7;11;""nips02dc1"";16929789;1431768569067; ;95128847";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}