re = /^9+((\.9+)+)?$/m
str = '9
.9
9.
99
.9
9.9.9
99.99.
.99.99
99.999.999.99.9
9
9ad.99
.99.99
99.
^9+((\\.9+)+)?$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end