$re = '/^9+((\.9+)+)?$/m';
$str = '9
.9
9.
99
.9
9.9.9
99.99.
.99.99
99.999.999.99.9
9
9ad.99
.99.99
99.
^9+((\\.9+)+)?$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);