import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^9+((\\.9+)+)?$";
final String string = "9\n"
+ ".9\n"
+ "9.\n"
+ "99\n"
+ ".9\n"
+ "9.9.9\n"
+ "99.99.\n"
+ ".99.99\n"
+ "99.999.999.99.9\n"
+ "9\n"
+ "9ad.99\n"
+ ".99.99\n"
+ "99.\n"
+ "^9+((\\.9+)+)?$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}