import Foundation
let pattern = #"[\[\(<](?:no|NO|yes|YES)[\/,](?:yes|YES|no|NO)[>\)\]]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This operation bla bla bla...
// Closing marks
Confirm this command? [YES,no]
Confirm this command? (YES,no)
Confirm this command? <YES,no>
// YES,NO
Confirm this command? [YES,no]
Confirm this command? [yes,NO]
Confirm this command? [yes,no]
// YES/NO
Confirm this command? [YES/no]
Confirm this command? [yes/NO]
Confirm this command? [yes/no]
// NO,YES
Confirm this command? [no,YES]
Confirm this command? [NO,yes]
Confirm this command? [no,yes]
// NO/YES
Confirm this command? [no/YES]
Confirm this command? [NO/yes]
Confirm this command? [no/yes]
// DO NOT MATCH
Confirm this command? [YES,no,cancel]
Confirm this command? [yes,NO,cancel]
Confirm this command? [yes,no,CANCEL]
Confirm this command? [YES/no/cancel]
Confirm this command? [yes/NO/cancel]
Confirm this command? [yes/no/CANCEL]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)