const regex = /[\[\(<](?:no|NO|yes|YES)[\/,](?:yes|YES|no|NO)[>\)\]]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\[\\(<](?:no|NO|yes|YES)[\\\/,](?:yes|YES|no|NO)[>\\)\\]]', 'g')
const str = `This operation bla bla bla...
// Closing marks
Confirm this command? [YES,no]
Confirm this command? (YES,no)
Confirm this command? <YES,no>
// YES,NO
Confirm this command? [YES,no]
Confirm this command? [yes,NO]
Confirm this command? [yes,no]
// YES/NO
Confirm this command? [YES/no]
Confirm this command? [yes/NO]
Confirm this command? [yes/no]
// NO,YES
Confirm this command? [no,YES]
Confirm this command? [NO,yes]
Confirm this command? [no,yes]
// NO/YES
Confirm this command? [no/YES]
Confirm this command? [NO/yes]
Confirm this command? [no/yes]
// DO NOT MATCH
Confirm this command? [YES,no,cancel]
Confirm this command? [yes,NO,cancel]
Confirm this command? [yes,no,CANCEL]
Confirm this command? [YES/no/cancel]
Confirm this command? [yes/NO/cancel]
Confirm this command? [yes/no/CANCEL]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}