import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\[\\(<](?:no|NO|yes|YES)[\\/,](?:yes|YES|no|NO)[>\\)\\]]";
final String string = "This operation bla bla bla...\n\n"
+ "// Closing marks\n"
+ "Confirm this command? [YES,no]\n"
+ "Confirm this command? (YES,no)\n"
+ "Confirm this command? <YES,no>\n\n"
+ "// YES,NO\n"
+ "Confirm this command? [YES,no]\n"
+ "Confirm this command? [yes,NO]\n"
+ "Confirm this command? [yes,no]\n"
+ "// YES/NO\n"
+ "Confirm this command? [YES/no]\n"
+ "Confirm this command? [yes/NO]\n"
+ "Confirm this command? [yes/no]\n\n"
+ "// NO,YES\n"
+ "Confirm this command? [no,YES]\n"
+ "Confirm this command? [NO,yes]\n"
+ "Confirm this command? [no,yes]\n"
+ "// NO/YES\n"
+ "Confirm this command? [no/YES]\n"
+ "Confirm this command? [NO/yes]\n"
+ "Confirm this command? [no/yes]\n\n\n"
+ "// DO NOT MATCH\n"
+ "Confirm this command? [YES,no,cancel]\n"
+ "Confirm this command? [yes,NO,cancel]\n"
+ "Confirm this command? [yes,no,CANCEL]\n\n"
+ "Confirm this command? [YES/no/cancel]\n"
+ "Confirm this command? [yes/NO/cancel]\n"
+ "Confirm this command? [yes/no/CANCEL]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}