const regex = /^(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]), (25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]), (25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]), (25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]), (25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])$', 'gm')
const str = `Strings with negative numbers do not match. Leading
0's do not match, except when a number is 0.
0, 0, 0
211, 111, 011
000, 160, 255
Strings with a numeric value over 255 do not match
255, 255, 255
255, 255, 256
4-Digit numbers will not match
1, 11, 111
11, 111, 1111
Strings that contain more, or less, than 3 numbers, do
not match. Strings with dangling commas do not match.
111, 122, 133
111, 122, 133, 144
111, 122, 133,
111, 122
111
Numbers 0-9 are valid as long as the numbers they are used
to form are between 0 and 255
209, 183, 245`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}