#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]), (25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]), (25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])$"
Local $sString = "Strings with negative numbers do not match. Leading" & @CRLF & _
"0's do not match, except when a number is 0." & @CRLF & _
"0, 0, 0" & @CRLF & _
"211, 111, 011" & @CRLF & _
"000, 160, 255" & @CRLF & _
"Strings with a numeric value over 255 do not match" & @CRLF & _
"255, 255, 255" & @CRLF & _
"255, 255, 256" & @CRLF & _
"4-Digit numbers will not match" & @CRLF & _
"1, 11, 111" & @CRLF & _
"11, 111, 1111" & @CRLF & _
"Strings that contain more, or less, than 3 numbers, do " & @CRLF & _
"not match. Strings with dangling commas do not match." & @CRLF & _
"111, 122, 133" & @CRLF & _
"111, 122, 133, 144" & @CRLF & _
"111, 122, 133," & @CRLF & _
"111, 122" & @CRLF & _
"111" & @CRLF & _
"Numbers 0-9 are valid as long as the numbers they are used " & @CRLF & _
"to form are between 0 and 255" & @CRLF & _
"209, 183, 245"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")