package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:https?:\/\/)?(?:(?:www\.)?youtube\.com\/(?:(?:v\/)|(?:embed\/|watch(?:\/|\?)){1,2}(?:.*v=)?|.*v=)?|(?:www\.)?youtu\.be\/)([A-Za-z0-9_\-]+)&?.*$`)
var str = `https://www.youtube.com/watch?v=L-iepu3EtyE&ab_channel=systemofadownVEVO`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}