$re = '/offen kundig gut/i';
$str = 'open knowledge ist offen kundig gut';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);