$re = '/^[a-zA-Z0-9]+[._]?[a-zA-Z0-9]+$/';
$str = 'saeed.tabrizi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);