use strict;
my $str = '24,ELA.4,12,9.09
';
my $regex = qr/^(\d+),([^,]+),(\d+),([0-9\.]+)$/mp;
my $subst = 'UPDATE cbl_student_competencies SET BaselineRating = $4 WHERE StudentID = $1 AND Level = $3 AND CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2");';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";