import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"public(.|\n)+{"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
public ActionResult AddCompatibleWith(AttributeValue printer, string sku)
{
var isAuthenticated = _customerContext.LoggedInCustomer != null;
var model = new CompatibleWithModel();
if (isAuthenticated && _customerContext.LoggedInCustomer.SavedPrinters.Select(x => x.AttributeValue.Key).Contains(printer.Key))
{
model.Url = Url.Action(
"MyPrinters",
"Manage",
new
{
area = "my_account"
});
model.Text = SiteResources.View;
model.CssClass = "btn";
}
else
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}