$re = '/public(.|\n)+{/U';
$str = ' public ActionResult AddCompatibleWith(AttributeValue printer, string sku)
{
var isAuthenticated = _customerContext.LoggedInCustomer != null;
var model = new CompatibleWithModel();
if (isAuthenticated && _customerContext.LoggedInCustomer.SavedPrinters.Select(x => x.AttributeValue.Key).Contains(printer.Key))
{
model.Url = Url.Action(
"MyPrinters",
"Manage",
new
{
area = "my_account"
});
model.Text = SiteResources.View;
model.CssClass = "btn";
}
else';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);