using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"public(.|\n)+{";
string input = @" public ActionResult AddCompatibleWith(AttributeValue printer, string sku)
{
var isAuthenticated = _customerContext.LoggedInCustomer != null;
var model = new CompatibleWithModel();
if (isAuthenticated && _customerContext.LoggedInCustomer.SavedPrinters.Select(x => x.AttributeValue.Key).Contains(printer.Key))
{
model.Url = Url.Action(
""MyPrinters"",
""Manage"",
new
{
area = ""my_account""
});
model.Text = SiteResources.View;
model.CssClass = ""btn"";
}
else";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}