re = /^[0-9]* *([a-zA-Z]+[0-9]*)+( *\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))* *-> *[0-9]* *([a-zA-Z]+[0-9]*)+( *\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))* *; *[a-z][0-9]+( *\* *[0-9]*([a-zA-Z]{1,2}[0-9]*))*$/m
str = '2H2 + O2 -> 2H2O; k1*H2*H2*O2
C + O2 -> CO2; k2*C*O2'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result