$re = '/(?<twas>(?<twisting>[5])|(?<armstand>[6]))?(?<direction>[1-4])(?<flying>(?(twas)[ ]?|[0-1]))?(?<summersaults>[(]?(?:[1-9]|1[0-2]?)[)]?)(?<twists>[(]?(?:[1-9]|1[0-2]?)[)]?)?(?<position>[a-e])/iA';
$str = '6273C';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);